[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]
> - If we do not want to stick with the C11 API (its emulation), then I
> would suggest to use the similar terminology, e.g. atomic_load_relaxed()
> and atomic_store_relaxed(), or Linux READ_ONCE()/WRITE_ONCE(). There is
> no reason invent new terminology; it might just add more confusion.
i really do not like the "once" name.
even though i'm familiar with the actual desired semantics,
i have to ignore my builtin meaning that comes first. to me,
"once" initially reads as compiler will only do it one time,
ever, not every time it is called. like pthread "once".
can we make them __read_always() and __write_always()?
Main Index |
Thread Index |