tech-kern archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

broadcom 57766 and jumbo frames


New iMac have a broadcom 57766, which is handled out of the box by the
bge(4) driver in -current. The driver almosts treats it as a 57765, 
which seems almost correct when looking at Linux driver contributed
by Broadcom:

Unfortunately, jumbo frames do not work either on 57766 nor on 57765
on NetBSD. I tried telling it was jumbo capable without much success. 
I also tried to incoporate some tweaks from the Linux commit above, 
but it does not help.

It seems impossible to send or receive anything beyond around 1500
bytes with mtu set to 9000. I note that ifconfig still reports ec_enabled=0
I wonder if it is a problem with 57766 specific adjustements, or if it is the
bge(4) driver itelf that is jumbo frame incapable for now.

Anyone had jumbo frames actually working for another bge(4) board? 

Emmanuel Dreyfus

Home | Main Index | Thread Index | Old Index