tech-kern archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: sysctl node names (Re: CVS commit: src/sys/uvm)

>> the current mixture of "enable" vs "enabled" seems ugly to me.
>> if my preference matters, i'd say "enable"/"disable".
> For me, "enabled" sounds more logical because such a flag refers to a
> state, not a process.

I'd say it's a question of whether you think of them as input to the
kernel, commands ("enable this"), or as output from the kernel,
reporting state ("this is enabled").

Of course, in most cases, they're actually both, so that doesn't help
much.  But, as a native anglophone, it's what the difference between
"enable" and "enabled" here feels like to me.

/~\ The ASCII                             Mouse
\ / Ribbon Campaign
 X  Against HTML      
/ \ Email!           7D C8 61 52 5D E7 2D 39  4E F1 31 3E E8 B3 27 4B

Home | Main Index | Thread Index | Old Index