tech-kern archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: UVM typedef struct

> honestly, if you going to do this, please rename all the "struct vm_foo"'s
> to "struct uvm_foo".  the current method with some of each is historical
> baggage to the integration of UVM and it has always bothered me.
> that would also avoid any confusion for folks with mach vm knowledge.

If we rename struct vm_map to uvm_map, it conflicts with uvm_map().
Semantically fine, but lose readability, greppability, and


Home | Main Index | Thread Index | Old Index