tech-kern archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Status of revivesa

On Sun, Sep 28, 2008 at 03:06:42PM +0900, Izumi Tsutsui wrote:
> wrote:
> > > Or, does the "compatibility problem" only affect chroot environments
> > > where any base libraries must not be updated?
> > 
> > Yes.  But all of that has already been discussed, you know.  You could
> > have read the archives.
> But many people commented that updating base would not pain
> while they didn't want to compile all binaries.
> They might not know the discussion.
> I'm just clarifying it again and asking if it's really worth
> to defer 5.0 for such limited compatibity issue.

To be clear, at this point, the main thing blocking merging SA is this
thread. So if getting 5.0 out the door is the main concern, let us merge
revivesa and get moving. :-)

AFAICT we no longer have any panics (PLEASE POST STACK TRACES IF YOU HAVE
A PANIC!!), so adding SA will not be a security issue. Yes, firefox has an
issue, but it 1) is restricted to itself, and 2) is something that can be
fixed (I believe) in a pullup to the netbsd-5 branch.

If we find that the issue can not be fixed, then we always have the option 
of turning the SA compile option off in default kernels.

Take care,


Attachment: pgpZ6Nt4P1nrw.pgp
Description: PGP signature

Home | Main Index | Thread Index | Old Index