tech-kern archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: revivesa status 2008/07/09

On Jul 11, 2008, at 12:30 PM, Manuel Bouyer wrote:

Be able to run a netbsd-4 or netbsd-3 userland on a netbsd-5 kernel.

I've come to believe that the ABI contract we should provide is between the apps and libc/libpthread, i.e. at the .so level. The kernel to libc/libpthread interface should be allowed to be more fluid.

Yes, I know that this will upset people who like static libraries, but frankly, I don't really care.

-- thorpej

Home | Main Index | Thread Index | Old Index