tech-kern archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Locking interface in "libprop" implementation

I suppose pa_rwlock & pd_rwlock could be renamed to the rwlock. There is more simple to resolve name disadvantage.

On Wed, May 7, 2008 at 2:51 PM, Matthias Scheler <> wrote:


the locking primitives in "libprop" are currently used like this:



This interface is IMHO a bit messy because in the case of stand alone
binaries neither "pd_rwlock" nor "pw_rwlock" actually exist. Is there
a reason why the interface doesn't look like this?



The only disadvantage would be that the member containing the lock
would have to use the same name in "_prop_dictionary" and "_prop_array".

       Kind regards

Matthias Scheler                        

With Best Regards,
Andy Shevchenko

Home | Main Index | Thread Index | Old Index