tech-kern archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Locking interface in "libprop" implementation

On Wed, May 07, 2008 at 03:15:21PM +0300, Andy Shevchenko wrote:
> I suppose pa_rwlock & pd_rwlock could be renamed to the rwlock.

Yes, of course. That was the idea.

But I would actually prefer an implementation specific name. The kernel
version could add a member "k_rwlock", the userland implementation
a member called "pt_rwlock".

        Kind regards

Matthias Scheler                        

Home | Main Index | Thread Index | Old Index