[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]
Re: CVS commit: src/sys/sys
On Wed, Dec 31, 2008 at 03:21:04PM +0000, Christos Zoulas wrote:
> >> From the name, I would think it ought to be fsid_t, but it looks as if
> >> that's a red herring and it was left partway through a cleanup that
> >> intended to change it to fsid_t later. Or something like that.
> >Hm, yes, possibly. It appears that fsid_t is a 64-bit non-integral
> >type, so changing it to that right now as an alternative to this
> >"point fix" would have possibly wide-ranging consequences, and would
> >certainly change the binary layout. On the other hand, I had already
> >verified that the simpler fix worked as a "build fix"; I had
> >successfully completed several port rebuilds with this fix in place,
> >so I concluded that it ought to be good enough for now.
> In the christos-time_t branch va_fsid is dev_t and sizeof(dev_t) ==
> sizeof(fsid_t) since dev_t is uint64_t. We did not want to change
> the binary layout on head that is why we did not widen it.
Right. I mentioned this because maybe the half-finished cleanup should
be completed sometime... or if not, maybe the field should be renamed.
David A. Holland
Main Index |
Thread Index |