Source-Changes-D archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: CVS commit: src/sys/kern

In article <>,
Kamil Rytarowski <> wrote:
>Module Name:	src
>Committed By:	kamil
>Date:		Wed Nov  6 13:07:32 UTC 2019
>Modified Files:
>	src/sys/kern: subr_disk_mbr.c
>Log Message:
>Avoid unaligned pointer arithmetic in check_label_magic()
>Replace the logic of calculating the address with with base + offset.
>Reported by GCC8.

I consider this a false positive and the new code less readable. This looks
more like "appease the sanitizer"...


Home | Main Index | Thread Index | Old Index