Source-Changes-D archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]


Le 09/02/2018 à 00:42, a écrit :
On Thu, Feb 08, 2018 at 08:06:21PM +0000, Maxime Villard wrote:
  		af = AF_INET;
  		iphlen = sizeof(struct ip);
-		IP6_EXTHDR_GET(th, struct tcphdr *, m, toff,
-		    sizeof(struct tcphdr));
-		if (th == NULL) {
-			return;

is IP6_EXTHDR_GET misnamed or is it incorrect for use with non-INET6?

there is ip6 in the name but it performs a basic mbuf operation, it's not
incorrect to use it in ip4, so yes, a bit misnamed

Home | Main Index | Thread Index | Old Index