Source-Changes-D archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: CVS commit: src

On Jun 23,  4:14pm, (Taylor R Campbell) wrote:
-- Subject: Re: CVS commit: src

| I don't care if we rename them to consttime_memeq and explicit_memzero
| instead, but these are absolutely the operations that real crypto
| applications need.  consttime_memcmp and explicit_memset are not, and
| are needlessly complicated.

Only memcmp, memset to a value is easy. How about consttime_memequal()
and explicit_memset()?

| How do the attached man pages look?  We ought to add cross-references
| in memcmp(3) and memset(3) too, perhaps.

The attached pages look fine, but still refer to interfaces I'd rather not


Home | Main Index | Thread Index | Old Index