[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]
Re: CVS commit: src/sys
On Mon, Jul 02, 2012 at 06:15:50PM +0000, Manuel Bouyer wrote:
> Module Name: src
> Committed By: bouyer
> Date: Mon Jul 2 18:15:48 UTC 2012
> Modified Files:
... half the world :-)
> Log Message:
> Add sata Port MultiPlier (PMP) support to the ata bus layer,
> as described in
> While there, some cosmetic changes:
> - added a drive_type enum to ata_drive_datas, and stop encoding the
> probed drive type in drive_flags (we were out of drive flags anyway).
I'm not at all sure these changes are correct at all.
They are certainly difficult to follow.
In many cases there used to be ->drive_flags &= ~(DRIVE_ATA | DRIVE_ATAPI)
(and similar) which have the effect of clearing all the other flags.
This hasn't been carried forwards.
AFAICT DRIVE_OLD was always set at the same time as DRIVE_ATA.
So this should be a flag.
Although I don't think DRIVE_ATA and DRIVE_ATAPI should be set together,
there are clearly some code paths that only want to remove one of them.
I'm almost tempted to revert the entire patch, so that it can be
applied as several separate patches.
David Laight: david%l8s.co.uk@localhost
Main Index |
Thread Index |