[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]
Re: CVS commit: src/sys/fs/puffs
On Thu Jul 15 2010 at 20:03:37 +0000, David Holland wrote:
> On Wed, Jul 14, 2010 at 02:07:37PM +0000, Antti Kantee wrote:
> > Modified Files:
> > src/sys/fs/puffs: puffs_vnops.c
> > Log Message:
> > RENAME lookup semantics say return EISDIR if dvp = *vpp for the
> > last component .... obviously(!!)
> I take it that when you say *vpp, you mean tvp?
Of course not. That error comes from lookup to avoid do_sys_rename()
> (the alphabet soup effect is why I have been looking for better names
> for this crud)
> also I think the case you actually changed should be EINVAL?
I don't care as long as they're all the same (and nothing breaks ;).
Main Index |
Thread Index |