Source-Changes-D archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: CVS commit: src/sys


Alistair Crooks <> wrote:
> > Log Message:
> > Replace few USER_TO_UAREA/UAREA_TO_USER uses, reduce sys/user.h
> > inclusions.
> Maybe it's just me, but I do find the
> ...
> USER_TO_UAREA/UAREA_TO_USER abstractions much more informative, especially
> at a first glance. Would it be possible to keep them?

These macros are going to be removed, as discussed on tech-kern.  Basically,
uvm_lwp_getuarea() and lwp_getpcb() replace them, as these routines abstract
lwp_t::l_addr (which now should be renamed to l_pcb).  Apart from these and
MD code, l_addr/l_pcb should not be directly accessed elsewhere.


Home | Main Index | Thread Index | Old Index