Port-xen archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Problems booting NetBSD/Xen on Intel NUC 12 Extreme w/ i9-12900


I’m trying to run Xen on this new server. FWIW it is an UEFI boot from an M.2 disk with a GPT partition table.

I’ve installed 9.3 and it works perfectly. I’ve installed xenkernel413 and xentools413 but when booting into the xen hypervisor using this boot command (from /boot.cfg):

menu=Boot XEN_DOM0/amd64 9.3_REL + xen413:load /netbsd.XEN3_DOM0.amd64.9.3_REL.gz console=pc;multiboot /xen413.gz dom0_mem=256M

Xen complains about “Unrecognised CPU model 0x97” and after about 20 lines of output I get the final verdict:

Enabling IO-APIC IRQs
-> Using old ACK method
..MP-BIOS bug: 8254 timer not connected to IO-APIC
CPU0: No ire handler for vector e7 (IRQ -8)
IRQ7 a=……. Failed :(.

Panic on CPU 0:
IO-APIC + timer doesn’t work! Boot with apic_verbosity=debug and send a report. Then try booting with the ‘noapic’ option

So I’ve tried with the epic_verbosity=debug option and I get essentially the same result + a dump of details at the end. I can send a picture if that would help. Using the option “noapic” as suggested results in an immediate crash and reboot.

Next I tried 9.3 + xenkernel415 instead. Then the CPU is recognised (good!) and all probing of the CPU seems to work fine. At the end of the "(XEN)” output I see the message:

Scrubbing free RAM in background
Std. Loglevel: Errors and warnings
Guest Loglevel: Nothing (Rate-limited: Errors and warnings)
Xen is relinquishing VGA console

…and then it crashes. No reboot, only screen goes dark and the fans start spinning (as in the CPU is generating heat).

To me the xenkernel415 log output sounds like “all is good” (until it crashes). So I suspect that the problems with xenkernel413 are irrelevant, it is just a case of the CPU being too recent for 4.13 to recognise it.

Finally, I’ve tried 10_BETA + xenkernel 415. Exactly the same behaviour as with 9.3: all seems good with Xen and then it crashes at the point of handover to NetBSD.

But there are several questions even if we only focus on xenkernel415: 

1. Is this in any way a known problem? I.e. the situation where the Xen hypervisor seems happy enough, but something sort of breaks at the point of handover between Xen and NetBSD?

I’ve looked for the xentools415 package with no success. I see the xenstoretools-4.15, but those seem mostly useless, as there is not even an “xl” and conflict with xentools, so it is not clear when those are useful. I’ve also tried building the xentools415 package myself (but failed). 

2. How important is it to keep in exact sync between xenkernelNNN and xentoolsMMM? I.e. assuming I get past the current crash and get a running system with xenkernel415, is it imperative that I find a xentools415 to go with it or would xentools413 be sufficient?

3. When trying 10_BETA + xenkernel415 I notice that the distribution doesn’t include the kernel modules, i.e. /stand/amd64-xen/10.0/modules/ is empty. It seems that there is no difference in the .kmods between GENERIC and XEN_DOM0 systems, so I just copied them over. But it surprises me as one of the things that will be much improved with NetBSD 10 is Xen performance, so why then isn’t the distribution kit complete?

4. What should I try next to get this running?

All help with getting this running is appreciated.


Home | Main Index | Thread Index | Old Index