Port-xen archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Xen root filesystem on disk with gpt partitions

I have tried replacing the “dk1” part with the name of the partition as well as “NAME=name”, but neither works.  I have tried to use the “root” command prior to “load”, but that does not work either.

Is it possible to do this when booting Xen?

maybe with GRUB2?  here is a non-xen sample with casual "gptX" partition number.

menuentry "netbsd" {
        insmod ufs2
        set root=(hd0,gpt2)
        knetbsd /netbsd -v

apparently --root=wd0e is optional, works without it for GPT.

once that works, you can switch to XEN with something like that (draft).

menuentry "XEN" {
        insmod ufs2
        set root=(hd0,gpt2)
	multiboot /xen.gz loglvl=info guest_loglvl=info noreboot=true smt=1 ept=exec-sp com1=115200,8n1 console=com1,vga
	module /netbsd bootdev=... ro console=...

If you also want to enable serial console, I noticed on GNU/Linux that the console= argument still needs to be dom0's hvc0 and not ttyS0 for it to work.  Serial port seems to remains under control of the hypervisor.  Not sure how it goes for NetBSD dom0.

Setting up GRUB2


Home | Main Index | Thread Index | Old Index