Port-xen archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Where is netbsd-XEN3_DOM0.gz

On Jun 11,  3:06pm, "D'Arcy Cain" wrote:
} On 2018-06-11 01:36 PM, Manuel Bouyer wrote:
} > On Mon, Jun 11, 2018 at 12:26:38PM -0400, D'Arcy Cain wrote:
} >> The howto says that the DOM0 kernel is "copied from
} >> releasedir/amd64/binary/kernel/netbsd-XEN3_DOM0.gz of a NetBSD build".
} >> I built a kernel but I couldn't find that file.  I even ran "./build.sh
} >> -M/usr/obj releasekernel=DRUID" but still no joy.
} > 
} > netbsd-XEN3_DOM0.gz is a kernel built from XEN3_DOM0 config.
} > Not sure why releasekernel=DRUID should compile XEN3_DOM0.
} I was trying both ways.  The docs aren't specific that you have to build
} XEN3_DOM0.

     You can call it anything you want, but it obviously has to
contain the Xen related stuff.  If you want a custom kenrel (which
I do all the time) then I would start by copying XEN3_DOM0 to a
new file and editing it.

} >> I tried "./build.sh
} >> -M/usr/obj kernel=XEN_DOM0" and copying the resulting netbsd kernel
} >> after compressing it to /netbsd-XEN3_DOM0.gz but that totally failed to
} >> boot.
} > 
} > How did you boot it ? It should be booted as a module of the hypervisor
} menu=Xen:load /netbsd-XEN3_DOM0.gz console=pc;multiboot /xen.gz
} dom0_mem=512M dom0_max_vcpus=1 dom0_vcpus_pin

     This looks fine.  What was the error?

}-- End of excerpt from "D'Arcy Cain"

Home | Main Index | Thread Index | Old Index