Port-xen archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Where is netbsd-XEN3_DOM0.gz

On Jun 11, 12:26pm, "D'Arcy Cain" wrote:
} The howto says that the DOM0 kernel is "copied from
} releasedir/amd64/binary/kernel/netbsd-XEN3_DOM0.gz of a NetBSD build".
} I built a kernel but I couldn't find that file.  I even ran "./build.sh
} -M/usr/obj releasekernel=DRUID" but still no joy.  I tried "./build.sh
} -M/usr/obj kernel=XEN_DOM0" and copying the resulting netbsd kernel
} after compressing it to /netbsd-XEN3_DOM0.gz but that totally failed to
} boot.
} I am pretty sure that I have pulled that file from the build before but
} now it doesn't get built.  Did something get changed or am I missing a step?
} I am trying to get XEN 4.8 working on NetBSD 8.99.12.

     It really doesn't matter what the kernel is called or whether
it is compressed.  Just make sure that you have a line in /boot.cfg
that looks like this:

menu=Boot Xen with 6GB for dom0:load /netbsd.xen0 console=pc;multiboot /xen45-kernel/xen.gz dom0_mem=6GB dom0_max_vcpus=1 dom0_vcpus_pin

You can specify whatever memory size you want, but keep in mind
that all I/O goes through the dom0, I wouldn't go less then 512MB
(the above line is from my dev box where I only occassionally spin
up domUs).  Put the name of your kernel immediately after "load".
After "multiboot", you need to put the path to the Xen kernel.
Effectively, you are booting the Xen kernel and passing the NetBSD
kernel as "module" which the Xen kernel will load and execute (the
NetBSD kernel is not directly bootable).

}-- End of excerpt from "D'Arcy Cain"

Home | Main Index | Thread Index | Old Index