Port-xen archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: I can not get a SLES11 SP3 domU's virtual disk to initialize

On Sat, Nov 30, 2013 at 06:19:02PM -0800, Harry Waddell wrote:
> I have created SLES11 release, SP1 and SP2 domU's without issue, but I can't 
> seem to
> get an SP3 domU to work with my amd64 dom0 (netbsd-6 branch as of nov 30) and 
> xen 4.2 (from today's pkgsrc HEAD)
> but the same virtual disk image and nearly identical config works 
> fine with a SLES 11 SP3 DOM0. ( xen 4.2.2 )
> The disk is defined as 
> netbsd: disk=['phy:/dev/mapper/vg00-x43,xvda,w']
> linux: disk=[ 'phy:/dev/sdb,xvda,w'] 

Have you tried using a file: instead on NetBSD ?

> and the netbsd dom0 logical volume is _active_ with an exact byte copy of the 
> /dev/sdb from linux. 
> On NetBSD I get the dreaded: 
> > [    1.281542] xen-vbd: registered block device major 202
> > [    1.281569] blkfront: xvda: flush diskcache: enabled
> > [    6.380068] XENBUS: Waiting for devices to initialise: 295s...290s...
> On both linux and NetBSD I'm booting the domU with pygrub, so they should 
> both 
> be using the same ramdisk and kernel, have the same modules, etc... so I'm 
> assuming I shouldn't need to build a custom ramdisk, etc...?
> All I can think of at this point is that there's some incompatibility that
> has been introduced in SLES 11 SP3 that has created an issue with the 
> block driver. I think I've ruled out all the common mistakes, so I 
> can't think what else could be the issue. ( I also tried it with a file
> rather than an lvm, etc... just in case )

Have you checked the xen log files in /var ?

Manuel Bouyer <bouyer%antioche.eu.org@localhost>
     NetBSD: 26 ans d'experience feront toujours la difference

Home | Main Index | Thread Index | Old Index