Port-xen archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: NetBSD domU ksyms issue under xen and 4.2.3, not under 4.1.2

On Wed, Oct 16, 2013 at 07:20:04AM -0700, Jeff Rizzo wrote:
> On 10/15/13 5:05 PM, Jeff Rizzo wrote:
> >I ran into a weird problem today that I'm still not 100% sure the
> >root cause of, and can use some additional ideas for what might be
> >happening.
> >
> >I'm setting up a new dom0 host, a lovely 12-core box with 72G RAM;
> >it's running NetBSD 6.1.2/amd64 in dom0.  I launched a NetBSD
> >6.1.2/amd64 domU, and noticed vmstat wasn't working:
> >
> >domU14# vmstat 1
> >vmstat: undefined symbols: _allevents
> >domU14#
> >
> >After some poking around, it looks like the symbol table as
> >returned by /dev/ksyms is slightly corrupted - some symbols (but
> >not a lot!) are missing.  Weird.
> >
> >I have another system (dom0 - the one I'm replacing with the new
> >box) with the same 6.1.2 domU image (I verified the md5), and the
> >domU run on this system does NOT exhibit the problem.
> >
> >Since the new box was running Xen 4.2.3 (binary pkg from
> >ftp.netbsd.org), and the old box Xen 4.1.2 (package I built myself
> >a year or two ago), I tried backing out to the Xen package
> >on ftp.netbsd.org on the new box, and I got the same result.
> >
> >If, however, I tar up the xenkernel41 and xentools41 package from
> >the working system and install on the new box, the domU starts
> >working as expected!
> >
> a little more poking around reveals:
> - it happens when loading the kernel directly too (not just via pygrub)
> - it's related to the xentools package, not the kernel.  I was able
> to successfully use the kernel with the 4.1.2 tools package.
> One other thing to note is the working package is based on python
> 2.6, the nonworking ones on 2.7.

I got working 4.1.x with python 2.7, so I guess it's more a change in
xentools ...

Manuel Bouyer <bouyer%antioche.eu.org@localhost>
     NetBSD: 26 ans d'experience feront toujours la difference

Home | Main Index | Thread Index | Old Index