Port-xen archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Attempt at using Xen 4.1 on -current

On 05/19/11 16:35, Dustin Marquess wrote:
> Accidentally created the LV with the wrong size.  Went to go remove it
> and ran into PR bin/44947.

That one is a bitch :)

> Setup an OpenIndiana domU.  Works fine, go and add a phy:/dev/rsd0d
> disk to point to my 1TB ZFS drive.  VM boots fine, sees the correct
> drive size.  Go to zpool import it and:
> - zpool import completely hangs.  phy: seems broken. I've seen some
> mention of this problem w/ FreeBSD domUs here.  I don't believe
> there's a PR for it.

Have you tried passing a block device to phy there? I vaguely remember
OSOL (back then) disliking RD or BDs (don't remember which)

I don't think it's the same problem as with FreeBSD, because that is
something specific to HVM (FreeBSD/amd64 is HVM+PV, unlike NetBSD for

> The LVM patch is basically identical to haad's xen 3.3 patch, except
> it patches tools/ioemu-qemu-xen/block-raw-posix.c now.  The one issue
> I ran into was qemu seems to use a modified version of NetBSD's
> sys/queue.h and even defines _SYS_QUEUE_H_, so that the NetBSD version
> never gets included.  This means SLIST_ENTRY never gets defined, which
> breaks the sys/disk.h include.  Not sure of a clean way to solve this,
> so I just defiend SLIST_ENTRY in block-raw-posix.c, which is a bad
> kludge.  Not sure if this even works, as I ended up not even using
> LVM, but maybe this is used for phy: too?

Is the patch usable? Could you provide a link to download?

As a frequent -current + Xen user, and I'm sure others will agree, I
think it's very important that your effort isn't lost, lvm (and who
knows, ZFS) + xen will be something that people will surely be looking
forward to use in 6.0 (and brave early adopters/testers in -current).

Neither will work without the block-raw/block-raw-posix patches (for Xen
3.3.2 and 4.1, respectively).

The old block-raw patch was never incorporated in qemu or in pkgsrc, for
instance. To this day one has to patch xentools33 manually. But at least
*there is* a way! :)

At the moment I have no machine with 4.1 installed (had to revert,
because of this very problem) but I know someone who does. So there's
*at least* one extra tester :)


Home | Main Index | Thread Index | Old Index