Port-xen archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: call for testing: xen 4.1 packages

On 04/01/11 16:16, Manuel Bouyer wrote:
On Thu, Mar 31, 2011 at 11:57:19PM +0200, Christoph Egger wrote:
If you are on NetBSD-5 then pull up  dom0 balloon support from -current
then the error goes away.

I worked around this by using hw.physmem64 instead of the balloon sysctls
when they are not present (this is a 4 line patch).
I also had to patch vif scripts because 'vifname' is not present
on netbsd-5 (not a big deal either).
With both changes, I can start a domU with 'xm create -c' on a Xen 4.1

As blktap2 isn't useable on NetBSD yet, I disabled it in the package.
We can revisit this later, when blktap2 support is being worked on.

There is also some more plist fixes.

updated package at ftp://ftp-asim.lip6.fr/outgoing/bouyer/xentools41.tar.gz

Great thanks!

xl create still fails as before.
Has anybody been able to start a PV domU with xl on a NetBSD dom0 ?

I can start a HVM DomU with xl and HVM DomU. PV DomU fails for me, too.
I suggest to move the discussion about fixing PV DomU with xl to xen-devel.


Home | Main Index | Thread Index | Old Index