Port-xen archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

I/O errors in Linux domUs

I have a setup running where a NetBSD/amd64 dom0 hosts several Linux
domUs. All domUs have image files not partitions. So far, this is just
a test setup and I'm using images from stacklet.com (formerly
jailtime.org). However, I tried the Debian Etch (not available any
more) 64 bit, Debian Lenny 64bit and Gentoo 2008.0 64bit and always had
problems with I/O errors. While the Etch image ran ok for a while, it
started throwing errors when I moved it over to a freshly installed
NetBSD 5.0.1 (before it was on an older NetBSD-CURRENT). The other 2
would throw errors either on boot or as soon as I tried to edit a
config file. All image files are ext3

I didn't try with the Debian Lenny image but while I can mount the Etch
image via vnd, I cannot mount the Gentoo image (incorrect super block).
I've gone to great lengths to check the file systems on a Linux system
or even from the Etch system when it was running fine but was never
able to fix that.

What am I doing wrong? Or is it just the images I'm using?


Home | Main Index | Thread Index | Old Index