Port-xen archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Cannot see boot messages with DomU

John Hayward wrote:

My netbd config file has:
kernel = "/netbsd-INSTALL_XEN3_DOMU"
memory = 256
name = "netbd"
#cpu = -1   # leave to Xen to pick
#nics = 1
vif = [ 'mac=aa:00:00:50:02:f0, bridge=bridge0' ]
disk = [ 'phy:/dev/wd0f,0x01,w', 'phy:/dev/cd0a,0x2,r' ]
root = "/dev/wd0a"

/dev/wd0f is not mounted and is available

I'd say it's possible it's rejecting the mac address you are using. Besides the fact you probably don't want any white space in your vif line (I'm not sure if this is detrimental or not but I think it may be from memory), xen requires the use of a specific mac address, at least wrt the first 3 octets. These are:


Best way to generate this address though is to start a domu with no mac entry just vif = [ 'bridge=bridge0' ] and note down the mac address created when within the domu, then use that address within your config. Doing this will allow you to test the domu and at least remove that whitespace in the interim.
I've tried without a mac and no change.
I also tried without the root line (thought the comments in the How To seem to indicate it is required. I also tried with /dev/xbd0a buth
with the same results - no booting messages when starting.

You won't require the root line for a NetBSD domu, but if you did it would be /dev/xbd0a.

You can also remove the commented cpu and nics line as I believe they are not valid for xen3.
I commented them from the How To because they gave grief.

Give that a try and if you still have issues just holler.

I wonder if there is a problem with the DOMU kernel - I do see in xen info
about loading it.



Home | Main Index | Thread Index | Old Index