Port-vax archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: urtwn on VAX not working properly

2017-08-23 1:27 GMT+02:00 John Klos <john%ziaspace.com@localhost>:
> Any sort of transfer of data larger than a certain size [on urtwn(4)], though, fails. I
> could see the packets leave the VAX (well, at least the VAX thought the data
> was going out), but nothing appeared at the other end.

As you mention other hardware/drivers work better, it seems to be a
problem with urtwn(4), probably only in connection with slhci(4).
Can you test your urtwn(4) with another machine (with a "proper"
OHCI/UHCI/EHCI) to prove the latter?

Before Nick fixed it, umass(4) with slhci(4) had a very similar
problem that small transfers (block sizes) worked, while large ones
broke it after ~1 sec.

slhci(4) is a strange beast, I also have PR kern/51664 open for a USB
10/100 ethernet adapter (axe(4) at slhci(4))...
Nick is probably your first address here, he also has ISA hardware. :)


Home | Main Index | Thread Index | Old Index