Port-vax archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Building current

In article <20130404213653.7B65497129%rebar.astron.com@localhost>,
Christos Zoulas <christos%zoulas.com@localhost> wrote:
>On Apr 4, 11:20pm, bqt%update.uu.se@localhost (Johnny Billquist) wrote:
>-- Subject: Re: Building current
>| On 2013-04-04 15:20, Christos Zoulas wrote:
>| > In article <515D7041.3020607%softjar.se@localhost>,
>| > Johnny Billquist  <bqt%softjar.se@localhost> wrote:
>| >> Trying to build current natively on a VAX today gives a whole bunch of
>| >> errors of the form:
>| >>
>| >> /usr/src/lib/libc/gen/getpass.c(189): warning: conversion of 'unsigned
>| >> char' to 'int' is out of range [119]
>| >>
>| >> Anyone else seen this? Is it local to VAX only, or something other
>| >> platforms also see? I tried looking at the code, but my eyes rolled up
>| >> almost immediately.
>| >
>| > If you make 'c' 'unsigned char' do the warnings go?
>| Nope. Same error.
>| However, the error (from lint) seems silly. How can an unsigned char 
>| conversion to an int ever lead to out of range???
>Something is wrong with the vax lint description I guess.

Nope, looks like a vax gcc bug. Cross-compiled lint works just fine.

#   compile  libc/getpass.ln
CC=/usr/tools/vax/bin/vax--netbsdelf-gcc /usr/tools/vax/bin/vax--netbsdelf-lint 
-chapbxzFS -w -X 272 -d /usr/obj/vax/release/usr/include   -D_LIBC -DLIBC_SCCS 
-I/usr/src/lib/libc/include -I/usr/src/lib/libc -I. 
-I/net/quasar/src-5/NetBSD/src/sys -I/usr/src/lib/libc/compat/../locale 
-I/usr/src/lib/libc/compat/stdlib -I/usr/src/lib/libc/compat/../stdlib 
c/string -I/usr/src/lib/libc/../../common/lib/libc/arch/vax/string 
-D__DBINTERFACE_PRIVATE -I/net/quasar/src-5/NetBSD/src/libexec/ld.elf_so 
-I/usr/src/lib/libc/dlfcn -I/usr/src/lib/libc/gdtoa -DNO_FENV_H 
-I/usr/src/lib/libc/arch/vax/gdtoa -DWITH_RUNE -I/usr/src/lib/libc 


Home | Main Index | Thread Index | Old Index