Port-vax archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Installing -current

On Feb 20, 2008, at 4:31 AM, Johnny Billquist wrote:

Jan-Benedict Glaw skrev:
On Tue, 2008-02-19 10:27:10 +0100, Johnny Billquist <bqt%softjar.se@localhost> wrote:
Jan-Benedict Glaw skrev:
I'm failing to compile some of the more interesting packages with
NetBSD-4.0 . It seems -current should come along with the PIC- fixed
compiler and shared libs enabled. How do I install that on a naked
SIMH VAX? I tried to find some binaries, but it seems all the snapshot
and daily directories don't contain any VAX packages?
No, -current have shared libs and PIC fixed compiler, but it is also a broken compiler, along with a broken system.
Do you know what's actually broken?

Nope. I've tried looking at gcc a few times, but I just don't have the time or resources to get a grasp of the thing. But Matt fixed gcc 4.1.2. But 20070621 we imported gcc 4.1.3, and Matt's fixes got lost again, and we haven't had thing working since.

btw, I can do a clean release build on my amd64. So I haven't run into the
gcc bug yet.

On top of that, we also have the idlelwp changes, which came 20070518, which broke the kernel as such, on the VAX. Not fixed yet, either.


So there are no builds of -current for VAX, and haven't been for over six months...
To draw the line: There's no way installing a "current" VAX?


It appears that Matt might be working on something right now. He have commited some stuff in the last few days. I actually managed to build a kernel right now, if not a GENERIC one. But it don't boot. But I think (hope) that something will happen with that soon. So keep your eyes open.

How did it fail?

Home | Main Index | Thread Index | Old Index