Port-sun3 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

TME fpu problem

Hey folks,

I guess some around here have already played with TME, and I may be
doing some stupid user mistake:

I've setup a TME instance emulating a sun3 160 (following the instructions
on the TME web page), and successfully installed NetBSD 6.1.2 on it.

Most things work fine, but when I run


it dies with:

Core was generated by `top'.
Program terminated with signal 8, Arithmetic exception.
#0  0x02078430 in floor () from /usr/lib/libm.so.0

and looking there:

(gdb) x/16i floor
   0x2078406 <floor>:   fmovel %fpcr,%d0
   0x207840a <floor+4>: fmoved %sp@(4),%fp0
   0x2078410 <floor+10>:        fbun 0x2078434 <floor+46>
   0x2078414 <floor+14>:        fboge 0x2078422 <floor+28>
   0x2078418 <floor+18>:        fmovel #32,%fpcr
   0x2078420 <floor+26>:        bras 0x207842a <floor+36>
   0x2078422 <floor+28>:        fmovel #16,%fpcr
   0x207842a <floor+36>:        fintd %sp@(4),%fp0
=> 0x2078430 <floor+42>:        fmovel %d0,%fpcr
   0x2078434 <floor+46>:        rts
   0x2078436 <floor+48>:        nop
(gdb) info reg d0
d0             0x0      0

So writing to the FP conroll register already worked before, but now restoring
the saved value fails?

Is this a TME bug, or did I miss something in the configuration?


Home | Main Index | Thread Index | Old Index