Port-sparc64 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: bge fail on netboot of NetBSD-6 on v215 and v240

(2013/05/15 11:43), Masanobu SAITOH wrote:
Hi, macallan.

(2013/05/14 19:59), Michael wrote:

On Tue, 14 May 2013 03:42:16 +0900
SAITOH Masanobu <msaitoh%execsw.org@localhost> wrote:

(2012/10/18 2:47), Michael wrote:

On Oct 17, 2012, at 2:08 AM, Erik E. Fair wrote:

I took the latest distribution/builds of netbsd-6 and tried to
netboot them this evening on a Sun Fire v215 and Sun Fire v240.

Both got ofwboot.net fine, and loaded the GENERIC (MP) kernel fine
(though the v215 complained about the aceride tc_count), but when
it came time to mount NFS root, both failed: bge0 watchdog timeout
-- resetting (resulting in "cannot mount root, error = 79").

Have we screwed the pooch in interrupt routing, again?

I see the same on a Blade 2500 - on some bges our driver doesn't work if OF 
touched the hardware first, it works fine if you boot from something else.

have fun

  Is this problem still alive in -current?

Can't tell, the kernel crashes with an illegal access to PCI config space right 
after bge establishes its interrupt handler.
( sorry, didn't have time to dig any further yet - the fault comes from 
schizo_conf_read() )
Same when booting from harddisk.

have fun

  Alignment problem?

 I tested with Netra T1 + BCM5705K NIC(non on-board). It worked.

bge0 at pci3 dev 15 function 0: Broadcom BCM5705K Gigabit Ethernet
bge0: interrupting at ivec 3
bge0: HW config 00010054, 00000004, 00000000, 00000000
bge0: ASIC BCM5705 A3 (0x3003), Ethernet address 00:18:71:4d:3a:71
bge0: setting short Tx thresholds
brgphy0 at bge0 phy 1: BCM5705 1000BASE-T media interface, rev. 2
brgphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 
1000baseT-FDX, auto

sparc64# ping6 ff02::2%bge0
PING6(56=40+8+8 bytes) fe80::218:71ff:fe4d:3a71%bge0 --> ff02::2%bge0
16 bytes from fe80::250:43ff:fe36:342d%bge0, icmp_seq=0 hlim=64 time=3.164 ms

Could you show me the full dmesg?

                SAITOH Masanobu (msaitoh%execsw.org@localhost

Home | Main Index | Thread Index | Old Index