Port-sparc64 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: U80 console trouble

On Wed, 6 Feb 2013, Mouse wrote:

> Today (well, 2013-02-05 - yesterday, by now, in this timezone) I tried
> to run NetBSD/sparc64 on an Ultra 80.  I burnt boot CDs for both my
> mutant 4.0.1 (built on an E220r) and stock 5.2 (the 5.2 distribution
> install CD image from ftp.netbsd.org).
> The machine was finicky about booting from its DVD drive, but I managed
> to get each disc to boot.  Trouble was, when it prompted for the
> keyboard type after booting, it didn't accept input.
> The keyboard was working, and keystrokes were getting to the kernel,
> because L1-A dropped into ddb, and keyboard input worked fine in ddb.
> But after telling ddb to continue, userland still wasn't responding.
> That both 4.0.1 and 5.2 exhibited identical trouble leads me to suspect
> it's something systemic.  But I have no idea what it could be.  Anyone
> have any thoughts?  I could probably track this down, given time,
> motivation, and sufficient access to the hardware.  I don't really have
> any of those at the moment, though. :(
> If I've left out information that's likely to be relevant, just ask.  I
> have access to the hardware in that I can burn a test CD and take it
> over there, but that takes arranging an appointment and a trip a
> significant distance across the city; it's not something I can do on
> short notice or with fast turnaround.

Need a whole bunch of info:

What sort of keyboard?

How is it attached?

What are the OBP device nodes involved?

Can you get messages of the kernel trying to attach the keyboard?

What's the OBP `input-device'?


Home | Main Index | Thread Index | Old Index