Port-sparc archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Booting on raid1 rootfs

Le 23.02.2014 21:23, Martin Husemann a écrit :
On Sun, Feb 23, 2014 at 05:24:30PM +0100, BERTRAND Joël wrote:
        I have seen that sparc supports raid1 rootfs, but how can I install
bootblock ? I have tried in /dev/rsd1a and in /dev/rsd1c without any

Dim memory says I installed them to rsd0c and rsd1c (or whatever disks
make up your raid0). Maybe installboot should be smarter?


Original NetBSD installation was done on /dev/sd0a. I have created a raid1 array with /dev/sd1a and one absent disk.

I have tried to install bootblock with :
# installboot -v /dev/rsd1a /usr/mdec/bootxx /boot
# installboot -v /dev/rsd1c /usr/mdec/bootxx /boot

I can send installblock output this evening.

Installboot does not return any error. Some time ago, I have seen the same trouble on sparc64 and I have fixed it by installing bootblock on raid array instead of whole disk.

OBP can find boot block with boot disk1 or boot disk1:a, but is unable to find kernel on raid array.

Best regards,


Home | Main Index | Thread Index | Old Index