Port-sh3 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: landisk (Plextor) installation stuff



It used to work with 4.0_BETA2.

As the network rate really sXXXX, I wiped out the 4.0 install and tried a 
4.99.x ; but I can't have it booting anymore... And my serial cable is
dead so I don't know what has changed.


Le Ven 3 octobre 2008 20:48, John Klos a écrit :
> Hi,
> This is mostly borrowed from
> http://www.tokuda.net/diary.gns/200609b.html#1602 (it helps to have a
> Japanese-reading person around - thanks, Rieko!)
> I'm curious if someone can tell me if this is what I need to do to make a
> bootable NetBSD system (I have no serial console yet). It's mounted on
> another NetBSD system via a USB-IDE thingie, and therefore sd0. Also, the
> landisk tree from netbsd-4 has been build into /usr/dest-landisk/:
> dd if=/dev/zero of=/dev/sd0d count=1000
> dd if=/usr/dest-landisk/usr/mdec/mbr of=/dev/rsd0d bs=512 count=1
> fdisk -0 -u /dev/sd0d
> (don't change what BIOS thinks, sys ID 169, start 63, use the rest of the
> disk, no bootmenu, don't update bootcode, write to disk)
> fdisk -a sd0
> (want to change, select partition 0, happy, write)
> disklabel -i -I sd0
> (a, 4.2BSD, 63, `disk minus swap`, b, swap, a, $, e, unused, 0, 0, W, y,
> Q)
> newfs /dev/rsd0a
> installboot -m landisk -v /dev/rsd0a
> /usr/dest-landisk/usr/mdec/bootxx_ffsv1
> mount /dev/sd0a /mnt
> cp /usr/dest-landisk/usr/mdec/boot /mnt
> (in sh)
> cd /mnt
> for file in /usr/dest-landisk/sets/*.tgz; do tar xzpf $file; done
> cd /mnt/dev ; ./MAKEDEV all
> vi /mnt/etc/master.passwd (add account(s))
> vi /mnt/etc/group (add groups and account(s) to wheel)
> vi /mnt/etc/fstab
> /dev/wd0a / ffs rw,softdep 1 1
> /dev/wd0b none swap sw 0 0
> /kern /kern kernfs rw 0 0
> /proc /proc procfs rw 0 0
> vi /mnt/etc/rc.conf
> (configured=yes, hostname, sshd=yes, dhclient rtk0, et cetera)
> pwd_mkdb -L -d /mnt /mnt/etc/master.passwd
> Install the kernel, install the drive into the landisk machine, and boot?
> The problem is that I tried all of this, but it doesn't boot. Should
> installboot be run differently? I'm not familiar with MBR-type
> partitioning; did I do that incorrectly?
> Thanks very much,
> John Klos

Home | Main Index | Thread Index | Old Index