Port-sgimips archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: 6.0_BETA upgrade fails on Indy / Challenge S

On Fri, 16 Mar 2012 23:51:20 +0000
George Harvey <fr30%dial.pipex.com@localhost> wrote:

> I've been attempting to give 6.0_BETA a try but without any success. I
> have an external 4.3GB SCSI disk which currently boots 5.1 and which
> I'm trying to upgrade to 6.0_BETA. I've tried three different
> machines, all netbooting the install kernel, two failed extracting the
> base set and the third got past base and failed extracting comp. The
> machines are:
> R4600/133 Indy with 96MB RAM, failed with malloc errors while
> extracting base.tgz, I guess 96MB is no longer enough to run an
> install.
> R5000/180 Challenge S with 192MB RAM, failed extracting base.tgz with
> strange errors like "Cannot rename ./usr/share/locale/uk_UA.KOI8-U/
> to ./usr/share/locale /uk_UA.KOI8-U/LC_MESSAGES/SYS_LC_MESSAGES
> (Not a directory)" and "Cannot set permissions on (null) (Bad address)".
> R5000/150 Indy with 256MB RAM, succeeded in extracting base but failed
> to extract comp.tgz with "Command ended on signal".
> I might try an install next, instead of an upgrade, just to see if that
> makes any difference.

Tried an install on the R5000/150 Indy and it failed in the same place,
"Command ended on signal" just at the start of extracting the comp.tgz
set. Up until now, I'd been selecting a custom install and including the
comp, man and X11 sets. For my next attempt I tried just a minimal
install and that worked, it completed normally and I was able to boot
6.0_BETA from the hard disk.

Next step was to reboot into the install kernel again and try adding
the extra sets. This time comp was extracted without error but the next
set, man, threw 'invalid header', data stream error', 'unexpected EOF
and failed. This suggests that sysinst is running out of some resource,
possibly RAM, when asked to extract multiple sets.


Home | Main Index | Thread Index | Old Index