Port-powerpc archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: NetBSD hangs while executing /sbin/init in IBM 405 GP eval board.

On Tue, 22 Mar 2011, mindentropy wrote:

>     I have a IBM 405GP evaluation board and I tried installing NetBSD on it. 
> NetBSD boots the walnut image properly and I am prompted for a boot 
> device(seletected emac0) and root filesystem(selected nfs). After that it 
> gives 
> me the correct information of the ip address of the device etc and ip and nfs 
> information of the server. After that it gives a warning of no /dev/console. 
> It prompts for a /sbin/init execution. After I return it just hangs there.
> To debug I tried to see what files its pulling from NFS and the last file it 
> queries and fails is libc.so.
> The whole problem described above happens in version 5.1
> I tried other versions too and went down to 3.0. In release 3.0 it does not 
> take any keyboard input for some reason. 4.0 suffers the same problem but I 
> could see MAKEDEV getting requested from NFS.
> Please provide some hints on fixing this. Cross posted here since I am not 
> sure 
> whether of-ppc mailing list is where I have to post.

ISTR that at one time the emac driver had issues and would hang.  I don't 
know if they ever got fixed.  I'd recommend adding a PCI network or 
disk controller and using that to access the root filesystem to see if it 
resolves your problem.  If it does, I can try to dig up some fixes I had 
made to the emac driver many years ago.


Home | Main Index | Thread Index | Old Index