Port-powerpc archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

NetBSD hangs while executing /sbin/init in IBM 405 GP eval board.

Hi All,

    I have a IBM 405GP evaluation board and I tried installing NetBSD on it. 
NetBSD boots the walnut image properly and I am prompted for a boot 
device(seletected emac0) and root filesystem(selected nfs). After that it gives 
me the correct information of the ip address of the device etc and ip and nfs 
information of the server. After that it gives a warning of no /dev/console. 
It prompts for a /sbin/init execution. After I return it just hangs there.

To debug I tried to see what files its pulling from NFS and the last file it 
queries and fails is libc.so.

The whole problem described above happens in version 5.1

I tried other versions too and went down to 3.0. In release 3.0 it does not 
take any keyboard input for some reason. 4.0 suffers the same problem but I 
could see MAKEDEV getting requested from NFS.

Please provide some hints on fixing this. Cross posted here since I am not sure 
whether of-ppc mailing list is where I have to post.


Home | Main Index | Thread Index | Old Index