Port-powerpc archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

RE: s3 product (Re: Xserver works on bebox with s3)

On 24-Nov-2008 KIYOHARA Takashi wrote:
>> It is likely to be able to refer to this patch with ibmnws and prep.
>> However, s3_drv.o did not support 'Vision 864' though I tried the support
>> with s3 on my prep.  I am looking at the source-code of old X now.
> My prep machine attached 'S3 Vision 864' on main-board.
> If the product of other S3 is attached(ex. Trio64), I might prepare Xserver
> for that.  Does prep have VGA other than Vision 864?

Good work on getting it running.  Thats awesome.

My 7248 has an 864:
vga0 at pci0 dev 14 function 0: S3 86C864-1 ("Vision864") (rev. 0x00)

It looks like a 7249-860 (the little laptop) has a different card, but I don't
own one of those:
vga0 at pci0 dev 14 function 0: S3 Aurora64V+ (rev. 0x00)

Having said that, I believe that the S3 driver in xorg and all xfrees after
3.3.6 (ie, the whole 4.x series) is broken.  I have a few i386 machines around
here with S3 cards, and while X works on them, it has all kinds of bad graphics
glitches, and other wierd issues.  I used to use S3 cards with 3.3.6 with no
issues, so I think it was broken in the big driver-rewrite that occurred in the
4.0 X.

Additionally, other cards I typically see in prep machines:

Weitek P9100 (VGA display) at pci0 dev 14 function 0 not configured
Cirrus Logic CL-GD5434-8 (VGA display, revision 0x8e) at pci0 dev 18 function 0
not configured

Also, I know of some machines that shipped with Matrox Millenium cards, so the
matrox driver would be handy to have too.

Tim Rightnour <root%garbled.net@localhost>
NetBSD: Free multi-architecture OS http://www.netbsd.org/
Genecys: Open Source 3D MMORPG: http://www.genecys.org/

Home | Main Index | Thread Index | Old Index