Port-ofppc archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pegasosII crash at boot with -current

matthew green wrote:

>> How current is your current? Mine is 6 days old, and a generic ofppc
>> kernel boots on my Pegasos2/G3 with 512MB.
> it was only a couple of hours old at that point.

Ok, then I will try it with a newer kernel in the next days and see what

>> It worked for you in the past?
> i haven't booted this system since april 2008, but yeah, it very much
> worked in the past, and the old install works (netboot or disk boot.)

Switching to gtpci was not a trivial task. I tested lots of modifications
from kiyohara@ in April until it finally worked on my G3.

But IIRC he also had a G4 with 512MB, so it should have worked for you at
some point...

>> Since the last months I get kernel panics when an USB device is
>> plugged in. I don't know if there was a modification in some USB code
>> or whether it is caused by a problem with gtpci:
>> [...]
> i've seen panics like this on my netbsd-5 amd64 desktop.  my netbsd-5
> tree has extra instrumentation around the code here, it shows that
> an alloc fails, and then the code goes bad.. but i haven't figured out
> much more than this about it yet.

That's interesting! So it is probably not caused by gt(4).

Frank Wille

Home | Main Index | Thread Index | Old Index