Port-macppc archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Cannot boot installer on PowerBook6,8

On Sun, Dec 3, 2017 at 3:46 PM, Sevan Janiyan <venture37%geeklan.co.uk@localhost> wrote:
> On 03/12/2017 20:26, Julio Merino wrote:
>> I've just got a PowerBook6,8 (the last G4 model, with 768MB of RAM)
>> and am trying to install NetBSD on it. Unfortunately... I haven't even
>> been able to even boot the installer yet :-( I knew this was going to
>> be difficult based on past experience with a Mac Mini, but this one
>> seems much harder...
> I have a 1.3Ghz 12" PB which runs -current fine.

That's good to know. This reports:

Apple PowerBook6,8 4.9.0f0 BootROM built on 01/10/05 at 10:39:14

What about yours? Just trying to rule factors out.

Did you recently install the system or have you just been going
through upgrades over time?

>> Here is what I get:
>>>> NetBSD/macppc OpenFirmware Boot, Revision 1.12 (Wed Nov 29 04:07:01 UTC 2017)
>> 6068324+127544=0x5e8e60
>>  start=0x100000
>> Decrementer exception at  %SRR0: 00000000  %SRR1: 00083030
>>  ok
>> 0 >
>> I've tried infinite combinations of: different partition schemes (MBR,
>> APT), different file systems (MSDOS, UFS, HFS, HFS+), different
>> versions of ofwboot (xcf/elf, and -current/5.0/5.2 because the one in
>> 5.0 is what worked for my old Mini) and even different media (mostly
>> from a USB stick, but also tried copying the loader and the
>> installation kernel to the existing HFS+ partition for Mac OS X). None
>> have worked, though sometimes the error changes to "invalid memory
>> access".
> Are you using a gzipped kernel?
> The ofwboot.xcf had an issue loading the kernel, stock, uncompressed.

Oh yes, I tried with a gzipped kernel as well, but the majority of my
tests have been with an unzipped one because I was under the opposite

Makes no difference though... I just tried gzipping it and trying
again to be sure, both with -current's ofwboot.xcf and an old
ofwboot.xcf from 5.0, and I get the same kinds of errors :-(

FTR, I remember that, on my Mac Mini, similar problems were caused by
the partitioning scheme / file system I chose to use as the
installation media. Only one of the many combinations worked but I
cannot remember which one. Once the system was installed, booting it
was never a problem though. (And now that I say that, I tried to
reconfigure my USB drive as the system would look (with APT and a tiny
HFS partition to hold ofwboot)... but didn't work.)

Which install media did you use (CD, USB, etc.)? Do you recall exactly
what specific setup you got to work?


Julio Merino -- http://julio.meroh.net/

Home | Main Index | Thread Index | Old Index