Port-macppc archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Cannot boot installer on PowerBook6,8

On 03/12/2017 20:26, Julio Merino wrote:
> I've just got a PowerBook6,8 (the last G4 model, with 768MB of RAM)
> and am trying to install NetBSD on it. Unfortunately... I haven't even
> been able to even boot the installer yet :-( I knew this was going to
> be difficult based on past experience with a Mac Mini, but this one
> seems much harder...

I have a 1.3Ghz 12" PB which runs -current fine.

> Here is what I get:
>>> NetBSD/macppc OpenFirmware Boot, Revision 1.12 (Wed Nov 29 04:07:01 UTC 2017)
> 6068324+127544=0x5e8e60
>  start=0x100000
> Decrementer exception at  %SRR0: 00000000  %SRR1: 00083030
>  ok
> 0 >
> I've tried infinite combinations of: different partition schemes (MBR,
> APT), different file systems (MSDOS, UFS, HFS, HFS+), different
> versions of ofwboot (xcf/elf, and -current/5.0/5.2 because the one in
> 5.0 is what worked for my old Mini) and even different media (mostly
> from a USB stick, but also tried copying the loader and the
> installation kernel to the existing HFS+ partition for Mac OS X). None
> have worked, though sometimes the error changes to "invalid memory
> access".

Are you using a gzipped kernel?
The ofwboot.xcf had an issue loading the kernel, stock, uncompressed.


Home | Main Index | Thread Index | Old Index