Port-macppc archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: 6.1.2 release cd doesn't boot

Tested Apple machines are indicated as well supported at this page:



FreeBSD and OpenBSD works well!

Il giorno 08/ott/2013, alle ore 18:18, Dennis Ferguson ha scritto:

> On 8 Oct, 2013, at 12:02 , Jeff Rizzo <riz%tastylime.net@localhost> wrote:
>> On 10/7/13 6:09 AM, Fabbri Matteo wrote:
>>> I have tried to install NetBSD 6.1.2 macppc on some Apple PowerPC G5 
>>> machines (iMac and PowerMac dual), but the cd doesn't boot…
>>> I have also tried with OpenFirmware boot instruction as described in 
>>> INSTALL documentation:
>>>> boot cd:,\ofwboot.xcf netbsd.maccppc
>>> but when it tries to load I receive this error message:
>>> … invalid memory access
>>> Do you have any idea?
>>> matt
>> Unfortunately, I don't think G5s are well-supported;  I think there are some 
>> patches floating around for a special kernel which may have some support, 
>> but it's definitely not in the release CD.  :(
> There's a POWERMAC_G5 kernel configuration in sys/arch/macppc/conf so this
> must have worked at some point, but last time I tried building that it had
> apparently bit-rotted.  The 64-bit processors can't boot an unmodified 32 bit
> kernel, the MMU (at least) is different, so that kernel would need to be
> resurrected.
> Dennis Ferguson

Home | Main Index | Thread Index | Old Index