Port-macppc archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Smoking gun: NetBSD 6.0.1 userland instability

I tried another experiment.

I fired up my NetBSD 5.2 system that ran my test case cleanly on the
6th of March.

I was unable at that time to run my test case with 6.0 userland with a
5.2 kernel, but I didn't think of running a 6.0.1 kernel with the
5.2 system.

Today I did that, swapping in the 6.0.1 stock kernel on the 5.2
system, and ran my test case.  This is the same, clean, 5.2 system - same
analog, same libraries, same everything.  Only the kernel is 6.0.1.

It failed.

I can say with confidence that this is a kernel problem, and one that
was introduced in the transition to 6.0.1.  Since I have already tried the
6.1_RC1 kernel, I can also say with confidence that it is not yet

This is a serious problem, because it is clearly corrupting data
in some cases.

I stand ready to help fix it if resources at my command can be of help.


Home | Main Index | Thread Index | Old Index