Port-macppc archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Problems with NetBSD 6.0.1


Although I have a few macppc systems already running netbsd-6, they were upgraded from older versions of NetBSD and they work fine. Today I tried to install NetBSD 6.0.1 from the macppc CD and I ran into several problems.

For starters, copying ofwboot.xcf to a small HFS partition and using that to boot the kernel off of the FFS filesystem, similarly to what's mentioned here, doesn't work:


Here's what happens:


I thought this might be due to the size of the kernel which is currently more than 8 megs, so I tried gzipping it. Now it boots fine, although USB is problematic, but I'll look into that separately. The same issue happens if the kernel or gzipped kernel is on the HFS partition.

Second, if the FFS filesystem is v2, the system panics when mounting. I don't have a picture of that yet.

Is this a known problem of ofwboot.xcf?


Home | Main Index | Thread Index | Old Index