Port-macppc archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: ppp on NetBSD 4.0.1 macppc

>In article <p06240801c5874d13cf92@[]>,
>Donald Lee  <MacPPC2%caution.icompute.com@localhost> wrote:
>>>In article <p06240801c58733f6ec5d@[]>,
>>>Donald Lee  <MacPPC2%caution.icompute.com@localhost> wrote:
>>>>I configured "pseiudo-device ppp 4" in my config file, and
>>>>built a kernel.  It's booting my kernel, and it looks like the
>>>>ppp stuff was built. ( I see if_ppp.o in the dot-o's)
>>>>Am I forgetting something?  Does ppp config require something else
>>>>in config options, like sl(4)?
>>>>Any clues for the clueless?
>>>ppp is a cloner device. You don't need the 4. pppd will create it as it
>>>needs to.
>>Oh...  Cool..  To be clear - I don't need to build my own kernel, then?
>>In that case, I'm ready to test the serial ports. ;->
>Try "ifconfig ppp0 create", "ifconfig -a". If it shows up, you are all set.
>if not your kernel does not have pppd.

Cool.  I can create up to 9 ppp devices on both the std kernel and the
one I built with "4".  The "4" in options looks superfluous, methinks.
(I only tried 9.  That's plenty for me.)

Being a basic troublemaker, and prone to neatness, I tried
"ifconfig ppp0 delete" and it fails. A (low-priority at best) bug?

        +mercy-t$ ifconfig ppp0 delete
        ifconfig: SIOCDIFADDR: Can't assign requested address



Home | Main Index | Thread Index | Old Index