Port-m68k archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: -m68060 breaks stuff in NetBSD-6


Hmm, I usually compile with -O2 -m68060 options and I didn't experience any failures due to compiler errors so far. My /etc/mk.conf looks like this:

COPTS+= -O2 -m68060 -Wa,-m68060,-m68851

Kernel and userland compiles just fine with this setting, last tested with HEAD trunk some days ago. I don`t use pkgsrc, I usually download the source archives directly from their host sites and do the classical ./configure; make install thing. I also set CFLAGS="-O2 -m68060" in my .profile so that ./configure automatically generates Makefiles with this two compiler options. All applications compiled this way worked for me so far. So I cannot confirm that there is some gcc problem with -m68060 option. -O3 is another story though.

Have you built userland with -m68060, installed it, then tried using it extensively? That's where we've run into issues. There's a similar problem with -m68040, but it manifests itself differently.


Home | Main Index | Thread Index | Old Index