Port-i386 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

gcc48, drmkms issues with i386

Finally installed i386-6.99.40 from sources as of about 201404071800Z.
I'd been running 6.99.38 built with HAVE_GCC=48 for some time, though.

pxeboot_ia32.bin is still broken.  Machine immediate resets when countdown
expires and loading the kernel is attempted.  This is true both for what
I compiled and downloaded from releng snapshots.  Reverting to a version
of 'pxeboot_ia32.bin' built with sources of 201404050000Z (so built with
gcc-4.5.4) works.

The GENERIC kernel works with text console:

vga1 at pci0 dev 2 function 0: vendor 0x8086 product 0x2562 (rev. 0x01)
wsdisplay0 at vga1 kbdmux 1: console (80x25, vt100 emulation), using wskbd0
wsmux1: connecting to wsdisplay0
i915drm0 at vga1: Intel i845G GMCH
i915drm0: AGP at 0xf0000000 128MB
i915drm0: Initialized i915 1.6.0 20080730

but, as expected, X with the intel driver will no-longer work with this

[    34.144] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
        i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
        915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
        Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
        GM45, 4 Series, G45/G43, Q45/Q43, G41, B43, HD Graphics,
        HD Graphics 2000, HD Graphics 3000, HD Graphics 2500,
        HD Graphics 4000, HD Graphics P4000, HD Graphics 4600,
        HD Graphics 5000, HD Graphics P4600/P4700, Iris(TM) Graphics 5100,
        HD Graphics 4400, HD Graphics 4200, Iris(TM) Pro Graphics 5200
[    34.146] (--) Using wscons driver on /dev/ttyE4 in pcvt compatibility mode 
(version 3.32)
[    34.146] (--) using VT number 5

[    34.152] drmOpenDevice: node name is /dev/dri/card0
[    34.157] drmOpenDevice: open result is 13, (OK)
[    34.157] drmOpenByBusid: Searching for BusID pci:0000:00:02.0
[    34.157] drmOpenDevice: node name is /dev/dri/card0
[    34.160] drmOpenDevice: open result is 13, (OK)
[    34.160] drmOpenByBusid: drmOpenMinor returns 13
[    34.160] drmOpenByBusid: Interface 1.4 failed, trying 1.1
[    34.160] drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0
[    34.160] (EE) No devices detected.
[    34.160] 
Fatal server error:
[    34.160] no screens found
[    34.160] 

Logged here in case anyone is wondering why their machine isn't working.

Booting the DRMKMS kernel did not produce a working system.  At some
point during the kernel messages, my screen turned black and there was
no further visible output.  The display (a VGA CRT) seemed otherwise
unperturbed by the video mode at which it was being operated.

Switching through the (presumed) virtual consoles with Ctrl-Alt-Fn
did not change the appearence of the display.

I waited what I figured was suffient time and tried logging in via SSH
but the connection timed out.

Since it operates diskless, I logged into the file server and changed
its default kernel back to GENERIC.

Although there was no display, the keyboard still responded and I was
able to blindly use Ctrl-Alt-ESC to drop to DDB and reboot the system.

|/"\ John D. Baker, KN5UKS               NetBSD     Darwin/MacOS X
|\ / jdbaker[snail]mylinuxisp[flyspeck]com    OpenBSD            FreeBSD
| X  No HTML/proprietary data in email.   BSD just sits there and works!
|/ \ GPGkeyID:  D703 4A7E 479F 63F8 D3F4  BD99 9572 8F23 E4AD 1645

Home | Main Index | Thread Index | Old Index