Port-i386 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

recent vr(4) change, trouble with net5501

I have a net5501 that used to run NetBSD 5.  I updated to -6, and it's
been fine for quite a while.  I just updated to -6 from yesterday, which
includes an improvement to vr(4) to not reset the chip when going in and
out of promiscuous mode.  (Before there was a ~1s hiccup when
running/exiting tcpdump.)

When I updated, I rebooted, and the machine did not come back onto the
net.  Visiting it and experimenting, I found:

  booting from applying power worked fine

  rebooting led to the system being up but vr0 being nonfunctional

  on the up/no-vr0 system, running tcpdump printed a message:
    vr0: using force reset command.
  and then it worked ok.

This is the change that I think might be relevant:

  sys/dev/pci/if_vr.c                             1.112 via patch

        Reset the vr(4) chip if the tx engine gets stuck.  No need to
        do a full reset when enabling/disabling promiscuous mode.
        [taca, ticket #783]

Or perhaps it's something else, and the device is left in a bad state
across boots.  I wonder if anyone else is seeing this.

(I posted a similar note to the soekris list.)

Attachment: pgpibhcCBIYoM.pgp
Description: PGP signature

Home | Main Index | Thread Index | Old Index