Port-i386 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: ACPI-Problems with NetBSD/i386 and a Compaq DL360 G1

On Thu, Aug 05, 2010 at 07:45:37AM +0300, Jukka Ruohonen wrote:
> On Wed, Aug 04, 2010 at 11:27:12PM +0200, the_badger%gmx.net@localhost wrote:
> > I am currently setting up a Compaq DL360 G1 Server with NetBSD (5.1_RC2).
> > While this worked perfectly so far with a single-CPU variant (after some
> > help from Matthias Scheler with a reboot-problem, see attached patch and
> > PR 38501), the kernel (my own patched one as well as -GENERIC) froze the
> > moment the first CPU was printed in green on the screen after I changed
> > from single to dual processor.  I was able to boot the kernel by disabling
> Posting the acpidump(8) output would be a good start. (Unfortunately, we
> probably need the so-called MADT table, which is neither possible with
> acpidump(8) in 5.x nor with acpidump(8) in pkgsrc/sysutils/acpidump.  So
> you'd need to boot to an alternative operating system to do that.)
> But compiling a kernel with ACPI_MADT_DEBUG defined and posting the output
> will likely do as well.

The older Compaq servers are a bit tempremental when it comes to
booting NetBSD.

One problem was a bug in our timer code which only manifested itself with
ACPI enabled and only on Compaq servers for some reason.  I fixed that a
couple of years ago.

Another is that the boot processor is often not the first processor noted
in the ACPI/MP tables.  For example, with 4 processors the boot CPU may
have APID 3, with the secondary/application processors having APIDs 0, 1
and 2.  This could cause problems with our code, although the last
time I booted a DL380 (which does this weird APID thing) it worked fine.
Would have been a couple of years ago also.  Perhaps worth checking out.

Home | Main Index | Thread Index | Old Index