Port-atari archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Aranym


just to share my latest success. I was finally able to install netbsd
(not boot, because I've got some NVRAM problems, i.e. it's rather
complicated to set it to NetBSD but I'll solve this today), I tell
you, this is really scary for anyone new to all this stuff:

- all tools use unix line endings, in practice you can't see more than
few words in TOS, i.e. errors, warnings, help, ... nothing will be
shown, just a garbage (I speak about TOS tools, of course, like
file2swp or loadbsd.ttp)
- installer has some kind of timeout for read operation (?), I tried
to make SWP on my SD card (SD to IDE converter), put sysinst there but
as soon as some data was requested from SWP (I think it was stage
around disk labeling or fsck), it timed out and returned to main menu,
really strange
- I took different approach, i.e. installing netbsd on that SD card
and making SWP (temporarily) on normal HDD => success!
- I was right, you can't use SWP on the same disk (or at least disk
area) as netbsd installation
- SWP is destroyed each time! (yes, even when totally separated on
another disk, I have to use file2swp each time I want to start
- disk label is somehow buggy: it offers me default disk label (like
"Samsung XY 1234" or "Addonics SD") but I can't set it because
'disklabel' tool can't work with white spaces and/or longer names! (I
chose "AddonicsSD" and finally succeeded in this stage)
- daily snapshot contains bad root path for ftp and even for directory
structure, I had to manually type everything (I admit, my fault, I
should use official release)
- after this, installation was quite nice and error/surprise free

To not only complain, I was amazed how different this is from FreeMiNT
for example -- you bootstrap kernel via .ttp and you've got everything
-- EtherNEC was detected, full hard disk was detected (i.e. ignoring
any HD Driver settings and limitations), installer took care of
everything, no single bit of knowledge of TOS was required, quite

Next step will be to make netbsd boot and then probably to cross
compile current kernel, then to try get Aranym running (if nobody else
do it before me). Btw, did anyone tried things like X server or even
more advanced DE? (XFCE, Gnome, KDE, ... ) I know it will be slow but
CT60 offers 500 MB RAM and CPU @ 100 MHz, it has to at least run :)

MiKRO / Mystic Bytes

Home | Main Index | Thread Index | Old Index