Port-atari archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: atari/dev/zs.c interrupt issue

On Sat, Jan 24, 2009 at 3:29 AM, Izumi Tsutsui 
<tsutsui%ceres.dti.ne.jp@localhost> wrote:
> Tuomo wrote:
>> I tried to transfer some files to my Falcon running NetBSD 5 kernel
>> with ppp. I'm using zs0b (ttyA1) device which is standard Falcon
>> serial port.
>> However I started to see "zs0b: ring overrun" messages early during
>> transfer and occasional freezing.
> Hmm, what baud rate?  I'm afraid zs can't handle >38400 bps.
>> It seems that BASEPRI() is causing this problem and following
>> patch cures this issue:
>  :
> I guess there are too many devices which use sicallback.
> As mentioned in machdep.c, most of them should be rewritten
> to use the MI softint(9) APIs directly.
> Could you try this one instead?
> (though I'm not sure this could help overrun issue
>  because "shortcut" path is removed in this patch)
> It would also be better to use the MI dev/ic/z8530* driver.
> (though it isn't so well designed)

I tried this patch and it works otherwise, but has also same overrun
problem that unpatched zs.c.


Home | Main Index | Thread Index | Old Index